802.1x / WPA2-Enterprise Wi-Fi won't connect - Missing fields


Has anyone succeeded in connecting to a 802.1x Wi-Fi with the Max 3?

On all other devices, when selecting a 802.1x Wi-Fi, we are prompted to enter a username and a password, as well as other connection information. On the Max 3, I am presented a box with only a spot to enter a password, like any other regular network. This makes it impossible to connect to my university network.

If I try to manually add a new connection using the “plus” sign, it doesn’t work either. I am asked to enter all the relevant information, but I end up having 2 networks with the same SSID, one asking me only for a password like it shouldn’t, and the other one hanging on the “Connecting…” status.

Thanks in advance for help :slight_smile:

Sorry for the late reply here. Could you please follow the tips via https://help.boox.com/hc/en-us/articles/360027999211-I-could-not-connect-to-campus-or-company-LAN-on-my-Boox-ereader-what-should-I-do- to connect the specified WiFi?


I cannot confirm anything right now because I can’t get out of home, but I already tried this. When I say I tried to manually add a new connection, I am talking about exactly the link you sent. The problem is that I end up having 2 connections, one asking me for a password (which is not normal for 802.1x), and the other one hanging on the “Connecting…” status.

It just does not work…

Thanks anyways!