All bugs and issues with firmware 2.2.2 (Note 2)

Dear Onyx Support, @claire

This will be a summary of all bugs and issues I encountered while using my Note 2. Attached you will also find some screenshots of the bugs and issues in the following list.

Notes App


  • Deleted backups remain in the backup folder. They are just removed from the backup interface.
  • When renaming a note both versions remain in the note folder and in the cloud backup (Dropbox). Every time a file is gonna be renamed, it will be copied with a new name and the old version will still be part of the cloud backup.
  • Deleted notes remain in the cloud backup. If I don’t check the checkbox, also the PDF in the note folder won’t deleted.
  • Palm triggers zoom, which makes writing impossible. You have to disable touch recognition in the sidebar, before writing a note.
  • The stroke width of the templates ist inconsistent. Some lines are stronger and others are thinner. The templates do need an update. (see IMG 8)
  • Syncing to OneNote is unreliable. Some notes are missing and only after a couple of times of synching they apper in OneNote.
  • The palm recognition does not work when using the lasso tool. If my palm rests/touches the screen, the selection is gone. This also happens, when I disable hand touch for the writing area. (added 2020-01-07)
  • When using a note template, then the lines that cross the lines of the template will remain over the lines of the note template after erasing. Only refresh will clear them finally (added 2020-01-27)
  • When using moving eraser to separate a line into two and then using the lasso tool to select one part of the line, still both parts of the line are selected. The moving eraser don’t separate them into two different elements. (added 2020-01-27)


  • When creating a backup, a name is forced. A name like “2020-01-03_notes” should be pre-filled instead.
  • You can’t update existing backups. You always have to delete a backup first and then create a new one. Most people will just keep one backup version. An update function for existing backups is really missing here!
  • There is no “sync all” function in the notes overview. When using multiple folders, you have to enter every folder and then select every note and then you can sync them. This is wasting a lot of time. There should be an “sync all” in the notes overview. Maybe in the burger menu.
  • The local note folder does not mirror the folder structure of the notes app. Instead for every note, it does not matter in which folder it is in the notes app, a directory is created with the name of the note. When two notes have the same name, the last synced will replace it. A manual backup of this folder is useless because of this. I would suggest to add another sub directory “notes” into the “note” folder, where the folder structure is mirrored. This will also make synchronizing more reliable.
  • A note with the name “backup” will be written into the backup folder.


  • There is an option “@2131822207” in the settings. What exactly is this?

Dictionary App


  • <rref> tags are not fully stripped / replaced from the Oxford Advance Learners Dictionary 8th Edition. If a dictionary entry contains <rref>z_forty_five_1_gb_1.wav</rref> in the dictionary appears z_forty_five_1_gb_1.wav"/>. This is quite ugly. (see IMG 5)
  • In Babylon dictionaries (BGL files) the id is not stripped from the terms. When I look for something like fight, the dictionary suggests me fightback$524075$. This happens to all free Babylon bi-directional translation dictionaries. In my case it was English-German. (see IMG 3)
  • Unicode characters are HTML entity encoded. This means that for example the polish letter Ł displayed as &#x141; in the dictionary suggestions. This makes it unusable for Polish people. (see IMG 1)
  • The order of dictionaries is ignored for the first search result. Sometimes the result of the second dictionary is shown but the first dictionary is highlighted instead. To get to the first dictionaries result, you first have to switch to the second and after you can see the results of the main dictionary.
  • Sometimes the formatting for German umlauts is strange in the dictionary. Sometimes it displays f ü r instead of für. This space is not part of the source code. I already checked it. (see IMG 6)
  • See also” links in the dictionary do not work. When I click them nothing happen. Instead the dictionary should lookup for this linked term. (see IMG 2)


  • The used font does not seems to fully support UTF-8
  • The steps between font sizes are too big. I can choose between 10, 15, 20. But maybe 12 will suit me better.
  • There is no import function for tarball archived stardict dictionaries. You manually have to extract them on your computer or with a app like “Solid Explorer” and copy them into the dicts folder. An import function would help here
  • You cannot switch between different languages of the online dictionary (wiktionary). There is only the one related to your system language available.

Reader App


  • If you rotate a pdf document in full screen view, it gets reflowed. The content fits the width of the whole screen instead of just beeing centered. (added 2020-01-05)
  • If you rotate a pdf document to landscape view, the home view gets rotated to landscape, too. You should only rotate the pdf inside the reader, not the whole screen. (added 2020-01-05)
  • Annotations and highlights created by other Boox devices like Nova Pro are not visible in Note 2 reader. (see IMG 11). When I open the same document with my smartphone and computer the annotations and highlights are visible (see IMG 10). (added 2020-01-05, @studio2054)


  • You cannot rotate pdf documents in split screen view. This is necessary for two column documents like you may often have when someone sends you a scan of a book as pdf. (see IMG 9) (added 2020-01-05)

Onyx Keyboard


  • Once disabled the notification of the Onyx keyboard, you cannot activate it again and therefor switching between keyboards is impossible. Long pressing the space key has no effect, which is usually the way all other keyboard solve this problem.
  • The text recognition for unknown words does not provide the word that was written. When I write something like “uBar” I have no chance, that the software recognize it. The software should always provide a suggestion that represents what I have written, letter by letter, as the first result. For example, instead of “uBar” I get these suggestions: a Bar, u Ban, U bar, or Bur, n Boer. These results are useless and I have to write letter by letter for this word. (added 2020-01-04)
  • Sometimes the keyboard switches randomly back to Chinese and then the text recognition of the handwriting input does not work. (added 2020-01-20)

Resolved Bugs

  • All special chars are wrong! So this is actually one of the most critical bugs! For example instead of a question mark ? (U+003F) the keyboard inserts a full width question mark (U+FF1F) and instead of a full stop . (U+002E) the keyboard inserts an idoegraphic full stop (U+3002). These special chars are not those English speaking people usually use. Actually in mail addresses and stuff like this, those special chars are not even recognized. (see IMG 4)

    Update: Thanks to @juk! The Chinese and the English keyboard do have both Latin letters. My keyboward was Chinese. Please ensure that “EN” is enlarged in the “CN/EN” switch of your keyboard. It is the third key from left in the last line.
  • The same wrong special chars are also in the handwriting input


  • There is only a Chinese (with Latin letters) and English keyboard layout. No German, French or other keyboard layout exists.
  • You should be able to switch between keyboards by long pressing the space char like in almost any other keyboard app.
  • In the handwriting input you cannot see the current selected language
  • After pen lifting time the input gets cleared. If the pen lifting time is too long, you always have to wait this time, until you get suggestions. Is the time too short, then your writings gets cleared and you cannot continue to finish the current term.
  • After restarting the device the keyboard is switched back to Chinese. (added 2020-01-06)

Improvements for handwriting

The text recognition suggestions should appear around 200ms (or better immediately) after pen lifting, but my handwriting shouldn’t be cleared. If I continue writing, then only the suggestions should be updated. This would allow me to write long words, sentences, mail addresses and to correct mistakes with the eraser of the pen. Only selection of a suggestion or space should clear the handwriting input after inserting the result into the text input. The return button shouldn’t change its behavior and should clear the handwriting as it does.



  • Sometimes when you return back home over the notification center from an app like a web browser, you have to tap two times until the apps menu open.
  • Sometimes the Boox does not recognize USB connection to a computer, so MTP file transfer, adb, etc. does not work. Restarting the Boox will solve this problem. Since this happens quite often I must restart my device every time I want to transfer files via USB. (added 2020-01-06)
  • Since the 11th of Januar 2020 Onyx Note 2 and Max 3 show no internet connection in the Wi-Fi settings, but actually are connected to the internet. It seems to be a false warning. (added 2020-01-11)


  • The security patch is quite outdated. On the Onyx Note 2 its still on August 2018! This is now over a year ago. The maximum should be at least 3 months for a professional device like this. (see IMG 7)
  • Notes and PDF app are not in the task manager. I cannot switch between notes, pdf and other apps.
  • The home button in the notification center always leads back to the Library. If I was browsing the storage, I have to open the folders again. The home button should return to the last opened view in the launcher.
  • The Library only scans the folder collection Books, WifiTransfer and Push or all folders in the storage. If I set it to all, even my exported Notes will appear here, so this is no option for me. What I am missing is the option to add custom folders. Furthermore there should be an “Documents” folder that should be included into the default “scan only specified directory in storage” setting. At the moment I store my pdf documents in Books, but it would make more sense to have them in a “Documents” folder. (added 2020-01-04)


As a long experienced software developer and software engineer, focused on improving and optimizing applications, especially the usability, I would like to join the Beta program to help you avoid such problems in the future. Some of this bugs are critical and should be fixed immediately.

Kind regards











IMG 10

IMG 11


That’s a great write up.
You should be compensated by Onyx for your effort to help improve their products.

Let’s hope someone from Onyx dignifies you with a concrete and substantive response to these separate issues.
And not with the too-common “forwarded to our relative colleagues” brush-off response.


You can enable or disable it by clicking the icon

You have to change the keyboard from chinese to english in order to get proper ?.:; and so on. It is done by clicking this icon and long pressing this icon works as switching keyboards, this works as typical spacebar function in other keyboards.


The order of dictionaries is ignored also in NeoReader dictionary.

@juk I do not have this zoom icon. Which device do you have? Maybe they fixed it in the Firmware 2.2.2 for Note Pro? Please see my last image in the opening post.

The CN/EN switch actually solved my special char issue. Thank you! I will update this in my post.

I will wait a couple of days and then create a FAQ for common user problems. Something like my how-to for adding custom dictionaries.

Update (2019-01-04): I added another bug for the Onyx keyboard. The text recognition does not work on unknown words. You will find the details in my opening post. If you have more bugs and issues, that I did not list or actually can solve existing, just write a comment and I will update my opening post after confirming them.

Sadly (and somewhat humorously), disabling the zoom gesture is useless, because it STILL pops up a “helpful” message telling me that I have zoom disabled, every time I lay my hand across the surface to write anything. The only real fix I’ve found is to disable touch completely in the drawing area, which is a shame because I’ve become very accustomed to the swipe gesture for turning pages.


I added another section with 2 bugs and 1 issue in the Reader app. I also added an identifier for alle images (IMG 1, IMG 2, etc.) and referred the related issues to them.

Thank you all for reporting these bugs to me and please don’t stop! If you encounter any issue, that is not listed in this post, then just let me know. Having all bugs and issues in one place must help the Onyx support resolving these as soon as possible.

I hope, that the support will soon pay attention to this post.

1 Like

Thanks for this very extensive list.

Lack of a french azerty keyboard is a real issue. We can use another keyboard but then can not switch easily to handwritingcrecognition.

1 Like

Update: A new issue with the lasso tool in the Notes app.

1 Like

If any of you encounter issues not listed, please let me now! I will validate and add them to my ongoing list and share this list to an Onyx support representative. I have contacted Onyx through various channels, and I am currently in a (slow) conversation with Onyx.

Hopefully they will acknowledge my support and accept me as an interface between community and developers. Since I am a developer myself, I know how to report issues in a more developer-friendly way and it is always easier to communicate with a single person.


Since getting my note pro, I can’t manage to make it connect to wifi. It works perfectly with mobile hotspot, but with my home it just doesn’t. I’ve tried it on every version of software, forgetting the wifi and restarting the router every time. My router is made by Asus and yes i’am trying to connect to 2.4 GHz (That’s usually the first response to problems like this.). I’ve tried to contact onyx through feedback but i’am unsure if they got my message since i didn’t get any mail confirmation.

You could try changing the WiFi channel (this is a different thing than the 2.4 GHz operating band) used by your router from the default. Could be that there are neighbouring WiFi access points operating on that channel to affect connectivity.


Can’t you connect or is your Wi-Fi network not visible in your Onyx? If you cannot connect, then this could have several reasons. First let me ask, when was the last firmware update of your router? Modern devices have a higher security requirements for Wi-Fi networks and if your router cannot fulfill them then you cannot connect.

I would try these steps first:

  • Reboot your rooter (Believe me, most people still don’t reboot their device before asking. If you already did, ignore this)
  • Try to change the encryption mode of your Wi-Fi password (WPA2, WPA-PSK, etc.).
  • As @HammockTime already said, maybe your channel is overloaded. In Wi-Fi 2.4 you have 13 channels and only 3 of them don’t overlap. Try 1, 6 or 11.

Kind regards

i also have the same issue , just open a ticket

i try using hot spot from iphone and android also the same "no internet "

@yardi @claire

I can confirm this issue. I have nothing changed, but since this morning my Onyx is connected to Wi-Fi but it has no internet connection. There are two log files in my storage.

You can find the logs here:

I will investigate this issue on my own, too. If I find a solution, I will let you know.

Update: My device does have internet connection but the status message is just wrong! Can you confirm this? Could you please navigate with your Browser through the internet?

I’m having the same problem. I thought my wifi truly wasn’t connecting, but you’re right-- I’m able to access internet just fine.

Wow, this is such a comprehensive and detailed list! Great job documenting @hazington!

This is my biggest gripe. I really don’t want to have to disable touch to take notes, there should be decent palm-recognition libraries out there that onyx can use.

IIRC this has to do with the rendering of templates, not the templates themselves. I’ve downloaded templates that I know to be uniform, and they also render with inconsistent width.

I installed a third party dictionary that uses the IPA alphabet to show how to pronounce words. For long enough words, I’ve had the whole first line be strings of these HTML-encoded unicode thingies. It’s super horrible.

The reason for the inconsistency in line strength is scaling. Onyx has changed the aspect ratio of the writing area, but has not updated the templates. The old templates must now be scaled to fit the new dimensions of the writing area. This always happens with scaled templates with thin lines, even on computers.

By the way. On my Note 2 the Wi-Fi issue has gone since this morning. It is possible that Onyx has set up its own captive portal server to check internet connection and that this server has been down yesterday.

Well, I’ve tried playing with channels and many other settings, and still when I try to connect the device just shows status “Saved, secured with WPA2 PSK”, that sometimes changes to “Scanning…” and “Connecting…”. I’ve managed to get the log from router when the device tries to connect "Deauth_ind [MAC] , status: 0, Station requesting (re)association is not authenticated with responding station ". I also want to emphasise that i’ve had this problem from the very beginning (on every software version), and I own Note Pro so it’s quite different from the issue the other people describe.