Boox note pro capacitive touchscreen not working


#1

Hi, I bought my Note Pro in July and it worked perfectly before. But from last week the touchscreen suddenly not work. The “About device” screen shows that the Capacitive Touch Version is “unknown”. I tried to download the update files and reinstall it multiple times, but the problem still exists even after I did a factory reset. Is this a hardware issue? Can anyone tell me how can I debug and fix it? Thanks!


#2

Following is the log I got from adb, the lines with stars seem to show the error…

[    2.294913] cyttsp5_i2c_adapter 1-0024: cyttsp5_init: INIT CYTTSP PWR gpio=170 RST gpio=251 and IRQ gpio=257 r=0
[    2.294932] cyttsp5_i2c_adapter 1-0024: cyttsp5_probe: Detect HW
[    2.370952] cyttsp5_i2c_adapter 1-0024: cyttsp5_xres: RESET CYTTSP gpio=251 r=0
[    2.557912] cyttsp5_i2c_adapter 1-0024: cyttsp5_xres: RESET CYTTSP gpio=251 r=0
[    2.744870] cyttsp5_i2c_adapter 1-0024: cyttsp5_xres: RESET CYTTSP gpio=251 r=0
**[    2.853797] cyttsp5_i2c_adapter 1-0024: cyttsp5_probe: No HW detected**
[    2.853824] cyttsp5_i2c_adapter 1-0024: cyttsp5_init: INIT CYTTSP PWR gpio=170 RST gpio=251 and IRQ gpio=257 r=0
**[    2.853841] cyttsp5_i2c_adapter 1-0024: cyttsp5_probe failed.**
[    2.853900] cyttsp5_i2c_init: Parade TTSP I2C Driver (Built TTDA.03.08.874312) rc=0
[    2.853916] cyttsp5_loader_init: Parade TTSP FW Loader Driver (Built TTDA.03.08.874312) rc=0
[    2.853931] cyttsp5_device_access_init: Parade TTSP Device Access Driver (Built TTDA.03.08.874312) rc=0
[    2.853967] cyttsp4_core_init: Cypress TTSP v4 core driver (Built 20130612) rc=0
[    2.854019] cyttsp4_i2c_init: Cypress TTSP I2C Touchscreen Driver (Built 20130612) rc=0
[    2.854051] cyttsp4_mt_init: Cypress TTSP MT v4 multi-touch (Built 20130612), rc=0
[    2.854065] cyttsp4_device_access_init: Registering device access device for core_id: main_ttsp_core
[    2.854100] cyttsp4_device_access_init: Cypress TTSP Device Access (Built 20130612) rc=0
[    2.854113] cyttsp4_loader_init: Registering loader device for core_id: main_ttsp_core
[    2.854145] cyttsp4_loader_init: Cypress TTSP FW loader (Built 20130612) rc=0

#3

Hello, please kindly submit this Service Request Form with all information needed, and our relative colleagues will reply as soon as possible.


#4

Hi, I have the same problem here !
Since some days the capacitive screen stopped working on my note pro. In was fine since I got it, then some weeks ago it started occasionally that after boot it wouldn’t work, but one or two reboots would fix it. Now it doesn’t work anymore. The stylus is still working though.

I tried to reset it, but now i have made it worse : it still doesn’t work, but now in Neoreader app, when i try to use the stylus to navigate it starts drawing on the file by default ! And so i cannot even make the neoreader settings bar to appear to disable the handwriting setting, result : i cannot use the device anymore…
A fix for this issue would be nice, i just need to disable handwriting !
Thanks


#5

I got exactly the same problem. I’ve been using my Onyx Boox Note Plus 10.3’’ since January without any issues. However, for the last few days I’ve been experiencing problems with the touchscreen. It becomes unresponsive, seemingly at random; I cannot select objects or turn pages, etc., although the pen and the back/power buttons work fine. The first few times I encountered this problem, it sorted itself out after a few minutes but this is no longer the case.

The hand touch option icon shows it’s on. The “Capacitive Touch Version” in “about device” is “unknown”.

I tried updating the firmware to 2.1.2. Not only didn’t this solve the problem, but it made its consequences much worse: now the stylus is enabled by default in Neoreader when viewing a pdf so there’s no way I can turn the page. I’m stuck with a single page on each document, rendering the device useless.

Did you manage to solve your issue? If so, how? Thanks.


#6

No, the problem still exists. I am still waiting for the Android 9.0 update, if it doesn’t work I am afraid we need to send it back to the retailer for fixing or changing.


#7

Sorry I can’t submit the Service Request Form, none of the situations suites me. I bought it when I was studying in China from the Onyx store in Guanzhou, but now I am working in UK, no idea how can I send it to Onyx from here. I have a plan to go back in China in the Holidays, but I only stay for two weeks, so I’m worried if it can get fixed before I fly back to UK…


#9

Hello, we also have a service center in EU. You could kindly send an email to service@onyx-international.com for the repair issue. Meanwhile, 2 weeks would be enough to repair the device if you come back to China.


#10

Hello, please kindly submit this Service Request Form with all information needed, and our relative colleagues will reply as soon as possible.


#11

Hello, please kindly submit this Service Request Form with all information needed, and our relative colleagues will reply as soon as possible.


#12

Sorry for the delay. The service center didn’t answer yet and the problem is still there. But for the neoreader issue you can find a link to the previous version of neoreader app that work with the new firmware, on this version the stylus isn’t enabled by default so you can use the device !! I found a link on a forum not sure where but you should arrive there…


#13

May I know your ticket number for your request? We will forward that to our relative colleagues to follow up and reply as soon as possible.


#14

I have the same problem with my Note Pro. Just as described by others, last week the touchscreen randomly stopped working. Now, it does not work at all. This is unacceptable for a professional device. I use this device day in and day out in the legal profession and should not have to waste time looking for solutions to tech problems on “Pro” devices under one year old. That these devices seem to be failing at the exact same time makes me wonder what the problem could be. It would be a startling coincidence if it was hardware and all these screens failed at the same time, but I don’t recall any software patches pushed out recently (at least none that I consented to). I am in Canada. What avenues for redress exist for me here?