Boox note pro capacitive touchscreen not working

I also had this problem. Then when I tried to drains the battery, I tried to reboot it for the last time but I disable hand touch and after rebooted it working again. At least for several days it working but now the problem come again and the method before seems doesn’t works. I hope this problem can be solved as soon as possible knowing many people are having the same problem.

1 Like

Hmm…feels like this is an software issue with initialising the touch hardware…

I found two other workarounds to make neoreader pseudousable again:

1.- You can connect a Bluetooth mouse/keyboard/presenter and use it to switch pages. In particular de mouse replaces completely the touchscreen, however it is quite inconvenient to carry around. The presenter is more limited but if you only want to switch pages works quite nicely.

2.- If you want to keep using only the stylus you can try the following trick: add to the navigation ball the fullscreens button. If you press it you get a message that fullscreen is not allow in this app. While the message is on the scribble mode is disable and you can turn pages by pressing the screen as usual, or even bring up the menu. Tricky but it works…

Hopefully onyx founds a real solution soon anyhow…

Hope this helps

Please kindly submit this Service Request Form with all information needed and our relative colleagues will reply back as soon as possible. The touchscreen problem shall be further checked.

The capacitive touchscreen issue shall be sent to Service Center and further check to define its cause. Apologize again for any inconvenience that has caused.

Could you kindly submit on Feedback via Settings/ Feedback on your device when you have repeat the second method? Our relative colleagues will reply back as soon as possible.

Thanks, I have done so.

Finally got it repaired. Sent my device on Dec 23rd and got it back today, it works perfectly now. Hope this problem won’t appear again!

1 Like

I have just upgrade to firmware 2.2.2. Sadly the problem persists. Hopefully onyx finds a software patch, as sending it back the device is not feasible to me.

In this case, it should be sent to the service center to further check. Please kindly submit this service form via with all info needed and our relative colleagues will reply back as soon as possible.

I have the same issue where the touch screen is not responding.
I bought this about 5 months ago in the US, I don’t even know if this is still under warranty. How do I check ?

I already filed a ticket and I got a reply saying I should pay for the shipping and mail it to Hong Kong ?! I paid almost 600 USD for this only few months ago and now I have to spend more money ?

I have exactly the same problem on Onyx Boox Note! Touch screen worked for about 8 months, then worked partially, now it doesn’t work at all, even after reboot. And this product costs freaking 600 bucks?! I will never buy an e-ink book from Onyx and will advice everybody to do the same. This company has no respect to their customers :frowning:

Yes, the device is still under warranty. Apologize for any inconvenience that has caused first. Later, we would have our after-sales service center in the USA. Please kindly send the device to further check or repair later in the US. Our team from After-sales Department will contact you later.

Apologize for any inconvenience that has caused first. Pls fill this Service Request Form with all info needed and our relevant colleagues will reply back as soon as possible.

I am now having the exact same problem. The pen works fine, but the touch does not work at all and the version is “unknown”. Previously a reboot would fix the problem, but now it does not. I already submitted a form related to another issue with the device freezing when trying to use the internet and the only response that Onyx can provide is to send it in for inspection/repair. However, this is not helpful since I am in Canada and shipping the device for inspection is far too costly.

The internet issue was annoying, but I could still use the device. This problem however makes the device unusable since I mostly use it for reading PDF’s, and now I cannot even turn the page. So, if anyone has found a fix for this that can be done by the user that would be very helpful. Perhaps there is a method in Android that allows rebooting the connection to the firmware?

Alternatively, does anyone know a way to turn the pages of a PDF using the stylus (and without downgrading to a prior firmware)?

Hi, I fixed this problem with finding an old version of the neoreader apk, which works just fine and that doesn’t activate the drawing with stylus mode by default, so you can turn pages with it. Since I only read pdf I don’t really see what I lost with an outdated version …

Can’t remember where I found the link, on a forum somewhere, so here is a wetransfer link if you want

Maybe Onyx don’t like us doing this but it would be easy for them to solve : just make the option in neoreader to draw with stylus disabled by default !

Also, just realized by reading another post before that you can use a bluetooth mouse on the device, thus you can open a document and disable the drawing option on neoreader and it will be applied for other documents as well ! … don’t know if it stays after rebooting yet though there is no option in systems to say “don’t enable drawingby default”, quite an easy fix at least. But now I am used to neoreader 2.0.1 haha

Thanks for the workaround. But now that so many people are having the same issue after a similar period of usage, I think this issue should be a hardware bug. So Onyx should take the responsibility to fix it for free and cover the shipping costs, and an extended warranty would be much appreciated.

The same happened to my note pro since a couple of months ago and now my device has become practically useless. Looks like it’s a really common issue and i do hope that boox could take it seriously and offer a reasonable solution to all of us.

Please kindly submit this on Feedback via Settings/ Feedback and our team will have a better and faster diagnosis of the problem.

I have the same problem…
I own an Onyx Note device since 2018 and 3-4 months ago it started to show problems related to responsiveness to finger touch. Sometimes the screen did not respond to the tactile stimulus, but after a restart or sometimes after two, the tactile function returned. Sometimes it came back after deleting a few third-party applications installed. I thought it was because of the software and I hoped that with version 2.3 this malfunction will disappear, but it was not. It continued to manifest itself almost in the same way by inhibiting the tactile function at almost half of the starts.
Now the screen no longer responds at all to the tactile stimulus, all the functions of the device having to be activated via the stylus even turning the pages when reading a book in Neo Reader.
I tried to go back to an older version of the software, I also tried to restore the factory settings but nothing happened. The screen no longer responds to the touch function.
I remember that one time after a factory settings reset I received a message like this: “To activate finger touch go to …”- I don’t remember exactly…
Finally I succeeded to get intouch with Onyx through feedback service and observed that in the device informations the capacitive touch version is unknown. They said that it need hardware check…