Bug in the digital buttons


This weekend I started using the Max3. The digital buttons voor back and close all apps and display all open apps (the circle, the two squares, I presume this is their function) only give me some flickering of the screen, nothing happens.
To go back to the main screen from within an app I have to click the back button until I’m on the home screen.

I do not know why byt I cannot make replies on my own conversation or any other conversation…

SOLUTION for the button bug: change the language to English!


Are you on the latest firmware? I just my Max 3 last week and there was an update that was available then.


I have the same problem with the digital button. And on the device there is (at the moment) no update available


What’s your version number? I wonder if you’re running different firmware from me. There is the international one and the Chinese-market one, as far as I know.


Version number: 2019-09-06_18-10_2.2.1_2646f23

I run the device in German. Sometimes when I press the digital button, the message: “System-UI wird wiederholt beendet” appears. But sometimes it also gives me just some flickering on the screen.


Same version as me. See what happens when you switch to English. Could be that the glitch you’re seeing is due to the app not being able to find localized resources for the region you’ve chosen.


I switched to English and the digital button is working now without problem. Thank you for the hint.


the build number for Boox Max3 is 2019-09-06_18-10_2.2.1_2646f23


May I know which language do you use when come across this bug?


Noted with thanks. We will forward this bug to our relative colleagues. If you encounter the same bug, please kindly submit this on Feedback via Settings/ Feedback on your device.


When I use Dutcht this error occurs


Hello there,
Have the same issue here with french language.
In particular, the multitasking button isn’t working.

The bug also disappear for me when I switch the device language back to English.

I tried to submit a feedback via the device but I get “Network or server error, retry later” even though it is connected to the internet. So here I am.

Hope you will sort it out soon because it is painful for non english users.

Thanks !


Please kindly update to the latest firmware by going to Settings/ Firmware Update. That will fix the problem.


Noted with thanks. Will push our R&D team to fix it as soon as possible.