Can't download V2.1.1(20190417) [SOLVED]


#1

Hi Onyx,

update link of V2.1.1 for Max2 on http://www.onyx-international.com/ doesn’t work.
Can you fix?


#2

Hello Jack, we have double checked with the link, it works well. Could you kindly try again? And just click the “download” button from this link.


#3

Hi, thank you for reply!

Link on http://www.onyx-international.com/ still doesn’t work, but I’ve just download the update from link you have attached and it works good.


#4

Dear, please note that the link you provided is Chinese version. And please download the package from the link posted before. Thank you for your support.


#5

Here steps I follow to try download FW:

http://www.onyx-international.com/ -> Other Languages -> Support -> Downloads

After click on link it display as follow:

Immagine


#6

We have repeated the steps you posted and we could download the package. Could you kindly try again?


#7

Just tried and doesn’t works, but

works well.


#8

Hi Claire,

I can confirm that the official website link does not work if other language (e.g. English) is selected, nor does directly upgrading from cloud work, albeit the announcement (https://medium.com/@OnyxBoox/boox-firmware-2-1-changelog-5b85c520affd). Could you please make sure the firmware is rolled out? Thank you.

Edit: Actually, the link https://www.boox.com/downloads/ works, but http://www.onyx-international.com/ does not work.


#9

Dear, thank you for your message and we have passed this to our relative colleagues to follow up. You could try to update to the latest firmware by OTA now. Thank you for your understanding!


#10

The firmware update link in https://www.boox.com/downloads/ is not correct. Its embedded url is just “https://www.boox.com/downloads/”, so when you click it, you just get a page refresh, there is no way to download the update.

Please correct this.


#11

@Cheng You are right. https://www.boox.com/downloads/ no longer works, but I am pretty sure it worked. The update v2.1.1 is really amazing. If you do not want to wait until Boox fixes this problem, you can access the update file I saved in my Google Drive (https://drive.google.com/open?id=1HHNnoHI11DqFXA7cZ3TjA77XiEpcm3dD) when the link worked. Please note that it is ONLY for Max 2, NOT for MAX 2 pro.


#12

Dear user, we recently updated the firmware to version 2.1.1, which may cause bugs during use. This update has been temporarily suspended and we are currently developing a fix for these issues. The fix will be announced on our official website and social media once it is available. Apologies for any inconvenience caused and appreciate your understanding.


#13

#14

#15

Is there any ETA on when the 2.1.1 firmware will be available again? I’d really love to try it out :heart_eyes:
Thanks!!


#16

I have and for me works well. (I use Max2 for note taking only, so I don’t know if other features are bugged…)
How can I share file? (736MB)


#17

That’s very kind of you jack,
knightgu also shared the file some posts above so I guess I could download it there,
but since claire announced that version was somewhat “bugged” I was hoping for the final “stable” version to come out soon!


#18

Hello, our relative colleagues are keep working. Hopefully the next firmware 2.1.2 will be released in one month.


#19

Thank you for the heads up claire.
BTW… I couldn’t resist and downloaded the package from knightgu link above (thanks), tried it briefly (looks great!) and had no issues so far.

I don’t understand the necessity of WI-FI connection turned on to use the “handwriting recognition” function. Will it be the same on the new official update? I was very interested to try it but I have no WI-FI connection availble currently and so I couldn’t :persevere:

Anyway, t’s going to be an amazing feature, keep it on!


#20

Probably the recognition engine is not integrated and needs the network to download the information.