Feature: Setting to disable zooming in the note app

Dear Onyx Support

Since version 2.2.2 there is a zoom function in the notes app, but I do not really need it. Maybe others will use it. The problem is that the zoom function causes errors in the palm recognition and triggers the zoom instead of continuing writing.

I know that I can disable the hand touch within the writing area with the hand icon in the sidebar. But this is not a permanent setting and I have to remember to disable it in the next note. To avoid such problems, there should be an option in the settings to disable the zoom function within notes or the palm recognition should be improved to avoid misinterpretations.

Kind regards


I noticed this false triggering of the zoom function as well - it happens quite often. I do like the ability to zoom, though, so hopefully the palm recognition can be improved in order not to trigger zoom.

1 Like

I also suffer from the zoom feature - often when I start writing with the device laying flat on the table and the palm as well as the wrist are touching the screen, the zoom is triggered and the screen becomes frozen for several seconds, which is very annoying, as I use the note app quite a lot.

When I turn on the palm rejection, other features like selecting and moving text become quirky.

I don’t really use the zoom feature with notes, so I very much desire the option to disable it for the application.


The feature to disable the zoom function in Note App is available on Note Pro and other devices now. Please kindly click the zoom function to further select the disable one as below.


1 Like

This is only available in last year’s devices with firmware 2.2.2. Not in Note 2 and Max 3. Some people also complained that this setting is not permanent (you have to deactivate it in the next note) and that although the zoom is deactivated, an error popup appears instead that the zoom function has been deactivated. The zoom should remain permanently disabled, without warning.

Since I do not own Note Pro, I cannot confirm this myself. See here:


I mean you can just disable hand input. (the “hand” button below template) The message won’t pop up after disabling.

1 Like

new firmware sucks, i agree with you completely. the moment i begin to write, my palm has initiated zoom and the writing isn’t recognised. I have to hover my palm and begin writing first. causing me much grief

I personally really like the ability to zoom, I just wish the palm detection was better. IDK if it’s just never really been there and it just generally ignored touch input with the pen, but I don’t remember having problems like this in NeoReader, for example, which seems to be the codebase
where the zoom feature was borrowed from


+1. I had to hunt down this community just to report this issue. My preference for zoom would just be to not have pinch to zoom be a thing. It just doesn’t make sense on an eink screen. Just make it a button with a slider or not have it at all. Please revert this change, it’s really ruining the note taking experience.

Agreed, please allow us to disable the zoom functionality (without a popup telling you it’s disabled, it’s useless !).
Also, the button to block touch used to prevent you from accidentally clicking the buttons on the top of the screen. Now I often accidentally change pages when writing, and it’s frustrating (I end up going full screen to avoid this and constantly switching whenever I want to start a new page or go back to a previous page).

Throwing my hat in the ring here. I just got a Note Pro last week, and the zoom feature made the Note app so unusable that I was ready to return the device, until I figured out that the problem could be fixed by turning off hand input.

Still, now the device flips out trying to zoom while I write at least once in every meeting, because there’s no way to change the default setting for new notes. It is very aggravating, especially if I’m trying to quickly jot notes and this causes me to fall behind. I saw a separate thread requesting the zoom feature, and I can see how it could be useful for some users, but there has GOT to be an option to disable it by default (or improve palm rejection with the zoom feature on).

I second this! However, when you open a pdf, hand touch gets re-enabled again. This is something that needs to be fixed…

Sorry for the late reply here. This bug will be fixed in the next firmware update, according to our R&D team. Apologize for any inconvenience that has caused.

@claire, will the fix make zooming work better (no false triggering by the palm) or it will it just make the popup when it is disabled not appear?

Sorry for the late reply here. Per our colleagues, the fix for the zooming will be improved instead of simply making the popup disappear. Please be patient.