Google Play not authorised

I just received my new Note+ today, but I find problem when I tried to click into the google play apps, it pop up with page “this device haven’t beed authorised”, I had download the latest firmware and installed already it still not working, please enlighten me what should I do to make it work properly?


It looks like no more Google Play. But how was your experience updating the latest firmware?

This works on my Note+:

  1. Follow the instructions here

  2. Enable Play service in Setting

  3. Reboot the device and wait a few minutes and try accessing Play store again.

1 Like

Done, it works, thanks a lot

Actually, it is pretty simple.
Step 1:
Install the app “Device ID” to your device by below link.
Open it and find out the GSF.

Step 2:
Go to Google webpage for device registration.
Enter your GSF, and done the registration.

Step 3:
Reboot your device and go to Google Play once again. Congratulations. Problem’s gone now.

1 Like

Thank you for your suggestion.You can solve this problem though this method.We also will push a update to solve this later.

when can we expect the update? When 2.0 for Note+ available?

I have put in my Android Device ID which is 16 hexidecimal digits, (verified 16 digits long!) But I keep getting the error: "Value is wrong size, must be 16 (hex) or 19 (decimal).

Any ideas on why I am getting this error?

Will be release in this month.

@landylee . 2.0 release This Thursday? Will include Note+ ?

Not 2.0,will be an apk in the eink store.We will send a guideline to the users.

Hi, I can see a “Play store login patcher” has appeared in the eink store
For people who already used the link above to register their device,
do you still recommend to use the patcher either way?

Yes ,you can use this app to active the google play.