Google suite auto sign out after OS 2 update


#1

I have reactivated the play store as well as all Google apps several times after updating the OS to 2.0 on my device. I also updated the play store app to the latest version. It seems that each time Boox Max2 shuts down Google is deactivated. I can sign in again but have to do it for the play store, gmail, docs, etc. individually each time. I read an article that Google is gradually shutting out makers of e-ink devices. Unless Onyx comes up with a fix we may all be out of luck with the play store and all Google provided apps and services. In that case the value of an expensive tablet would be nearly nil.

I’d be thrilled if there is some simple work around I can’t find. Any ideas or people who have different experiences?

UPDATE: I tried this and so far it works: Settings/Application/GSF ID (bottom of the page). It says to press to register device to your google account. I did this and after a reboot I am still logged in to my google apps. I’m hoping this solved the post-update problem I experienced.

UPDATE 2: well, the fix lasted for a day and then the tablet signed itself out of Google again, saying I needed to enable Google Play I order to use their apps. I did and then had to sign back into gmail again. It had forgotten my email address and password. What a bother.

UPDATE 3: after a factory reset and careful one-by-one installation of apps I seem to have eliminated the problem. I’d guess it was any app called Rotation Control, though that’s just a guess.

UPDATE 4: MAX2 now signs itself out occasionally. I wrote to Onyx and they replied within hours. They say a soon to be released update called 2.01 will fix the issue with Google.


#2

I don’t know what is going on with your device. Mine does not do that. Measuring by the silence nor does other’s one.


#3

Thanks for the message. I guessed the same - with nobody else complaining it must be something in the settings of mine. Yours had no problems after updating the OS to 2.0?


#4

The google play app disappeared after 2.0 update, but as someone pointed it has to be enabled in settings. After enabling it worked straight without needing to re-login. Also google sheets works with my account even after reboot.


#5

I did activate the play store and registered the device with google (In the settings menu). Nothing prevented the signing out, so I did a factory reset last night. Google apps worked fine for a while (after downloading and signing in again), then signed themselves out after the device rebooted. Now I wonder if an ANdroid app is causing the problems?


#6

Most probably. If you make a factory reset, try not to install anything, just try the factory apps. Then after a while try adding them one by one.


#7

Thanks again. I ‘think’ I found the culprit. An app I was using called Rotate Control might be it. I haven’t reinstalled it and so far Google apps stay signed in. Fingers crossed!!!