Microsoft: Fix HDMI resolution by overriding EDID


#1

Hello.

There might be a fix for the blurriness issue:

Problem: When the Boox Max 2 is connected as a monitor using the HDMI the resulting image is blurry. The reason is that th HDMI connector suggests (through EDID) a resolution of 2104x1560 instead of the correct resolution of 2200x1650.

Solution: Microsoft says that it’s possible to override the wrong EDID: https://docs.microsoft.com/en-us/windows-hardware/drivers/display/overriding-monitor-edids

I’m considering to buy a Boox Max 2 but I’m hesitating because of the bluriness issue.
Did anyone try Microsoft’s solution succesfully?


MAX2 HDMI not useable: wrong display resolution
#2

Hi,

I tried to execute an equivalent of this on an older Linux laptop but failed in my initial efforts. I’m not sure yet what the cause is and haven’t tried to connect an Android Debugger yet to see what is going on. I also couldn’t select other advised resolutions during these tests so I may have put the Boox Max 2 in an inconsistent state. It may be possible to set the a different resolution but I’m not sure what settings would be needed.

It would be appreciated if others try to get this running too. I consider the “HDMI” feature to be false advertising as it doesn’t have the right resolution and it seems to always try to ‘optimize’ the display after setting the properties. Would be nice if we could get the right resolution with the right amount of colors through the EDID.

Kr,

Aad


#3

I recently had to fix a similar problem with an older monitor on Linux not detecting properly

from this article (or one similar to it) https://wiki.ubuntu.com/X/Config/Resolution/#Adding_undetected_resolutions

you should be able to do

cvt 2200 1650 30

this will return a bunch of stuff including a line that starts with Modeline

then do
xrandr --newmode “2200x1650_30.00”

then you should be able to do something like

xrandr --output HDMI-1 --mode 2200x1650_30.00

where HDMI-1 gets replaced by the name of the display that the Max is showing up as.

I’ll try to get more detail tomorrow, but hopefully this gives you enough hints to get things working (note, I don’t know what the correct frame rate is, I used 30 in the example because I’m very sure it’s not 60)

David Lang