My Onyx Boox Note device has disappeared from Google Play


#1

Hi

No answers to my first question so I hope this does better…

I read about installing apps I have already paid for onto my Onyx Boox Note 10.3 by logging into my Google Play account on a desktop, clicking on “Installed”, selecting the right device, and it gets installed over the air.

I did this yesterday okay for one paid app, but today the device has disappeared from the list of my devices in Google Play. I rebooted the Onyx Boox Note and checked that Google Play is enabled in Settings, but it still has not appeared.

Does anyone have the solution for this?
(Does Onyx read these posts?)

Thanks,
Richard


#2

happened to me with the max 2 some weeks ago while I was tweaking and trying the device.

I just disabled google play
reboot
enabled google play
reboot
open play store
login again
wait until update the play store and services
reboot
working again


#3

Hi @MrPaco

Thanks for this suggestion. Unfortunately, it hasn’t worked for me.

I wonder if Onyx changed something in the version 1.9 update that has broken this particular bit of the Play Store - everything else looks right, just not recognising the device :frowning:

If anyone else (Onyx???) can help it would be much appreciated.

Richard


#4

1.9 works fine, try opening the play store and see if it works and you can install things. Specially some app you bought before. If you can without play asking to pay again it’s not device problem but google account services.

if continue, just make a hard reset


#5

The Play Store itself runs ok:

  • I can log in ok.
  • It shows the apps I have installed on the Note.
  • It shows the full list of those I have installed on other devices.
  • I can install free apps on the Note ok.
  • But when I try to install a paid app that I have already paid for on another device it wants to charge me again.

So it is just one small part of the Play Store that is broken.

I am reluctant to do a hard reset as I don’t want to set it all up again!

Thanks,
Richard


#6

UPDATE: This now works okay.

I cannot guarantee these actions were what unlocked it, but this is what I did:

Application > Play Store > Three lines to the left of the ‘Google Play’ search bar > Settings

In the list that is presented I touched the “Play Store version” entry (which showed version 9) and got the message that “A new version of the Play Store will be installed”. I waited for a time but nothing appeared to happen. I left the machine for an hour or so and when I came back, turned it on, and checked the Play Store version, it was at version 11.2.14.

I went to a paid app that I had already paid for and was able to download it to the Onyx Boox Note.

The Onyx Note device is also now in my Google Play device list.

Richard


#7

Great, thanks for sharing!


#8

I told you before you needed to update play services and store :stuck_out_tongue:


#9

Hi @MrPaco

Unfortunately the Play Store and services did not update when I followed the steps that worked for you.

Nowhere in the Onyx documentation that I can find (there is very little!) does it say you initiate an update to the latest Play Store by touching on the entry in the Play Store settings.

I wish there was better Onyx documentation, but in the meantime I hope that people document their successes (and failures) in this forum so we can all benefit.

Thanks,
Richard


#10

I think this is really the problem of the google infrastructure itself. For me the play store service come up, when I tried to use google sheets app (after updating the app itself). It refused to start until I agreed to upgrade google play services.


#11

I can`t use it either, not after I use this:https://apps.evozi.com/apk-downloader/?id=com.facebook.pages.app


#12

This worked for me too. Takes a few minutes to update without any indication whatsoever… just go back in a few and check the version.

Thanks,
gat


#13

In the 1.9.1 update, there is a setting in Settings->Extension->Application Setting to ‘Enable Google Play’.

Why this becomes optional is probably to steer people to the Boox store where the apps are optimized for e-ink.