Neoreader Bug Opening from External Apps


#1

When would the long standing bug while opening Neoreader from external program be fixed?

It is in fact a very serious problem, the most important advertised feature is not working. At lot of user have their book collection in google drive, dropbox or somewhere else, and they are external apps that people expect an Android device should handle.

It is not a compatibility problem, since all other readers (Xodo, PerfectViewer, etc.) works when opening with external apps, only NeoReader crashes. But NeoReader has the best integration with the hardware of Boox, so it makes sense to keep using it.

I really love this Boox Note and recommended it to my friends and colleague, but this is a feature that people would expect when they buy the device.

These are the two related tickets since June last year, and more collected by @ybkishore







Install linux or alternate OS? (and GPL2 kernel source!)
#2

Onyx please fix this. I have seen several other posts besides the above two.


#3

I couldn’t agree more. Workflow and user experience for me as a scientist (who reads dozens of pdf papers directly from library services) is so bad that I don’t use my boox note anymore!
Please fix asap


#4

I would also like to add my own voice to these requests. This is an essential feature, and would make NeoReader so much easier to use.

I also use a mix of Dropbox and Mendeley to read pdfs, and need to spent too much time trying to get around the current limitations.


#5

Care to collect more? I want to make them aware of the seriousness of the problem.


#6

It is really such a basic feature that it should just work. I wouldn’t be surprised if half of the users are using Zotero or Mendeley to manage their papers.


#7

here are some more titles…


#9

Thanks, I’ll add them to the main thread.


#10

It seems that the feedback button in the setting would guarantee an answer from the development team, since I assume that it is connected their internal ticket system.

But the answer I got was not satifying at all, they don’t seem to understand that there’s a huge problem with the workflow, and that’s why people want an Android tablet from the first place.

I think you might stress the fact that it doesn’t event work with the internal browser, but it is anyway no excuse to have an Android tab without interoperability with 3rd party software.

======================================================================

Hello,

it cannot support open the download files directly from the 3rd APP for now , but you can open it from the storage folder .

Wing
Onyx International Inc.

发件人: info
发送时间: 2019-01-22 03:00
收件人: software; wing; pe; lin; wjf
主题: 错误反馈
(╯‵□′)╯︵┻━┻

错误信息:Hi, as you may know, neoreader crashes when opened from an external app like dropbox or google drive. even opening files downloaded from the browser isnt working. I have seen mutliple users discussing about the bug in the official forum with stacktraces. so please fix the bug. thanks!

型号:NoteP

MAC:undefined

软件版本:2018-10-15_17-19_1.9.1_d8846ab

时间:Tue Jan 22 2019 03:00:38 GMT+0800 (CST)

EMAIL: redacted@gmail.com

LOG: (╯‵□′)╯︵┻━┻

#11

Maybe we should all use the feedback button in the setting menu? That could help.


#12

In my case I am able to open any pdf file from dropbox / googledrive using neoreader and edit it. I am using Boox Max 2 with the latest available software. I do not have a problem opening or editing like you mention. My problem is neoreader makes a local copy (some temporary location user has no control over) and opens the file. Once open the edited file is saved back to a new folder with the same name as the file name (within the local location where the first file copy was made). This organization creates a huge headache… the edited files cannot be accessed from the cloud by other devices. Also imagine with 1000s of cloud files we have 1000s of new copies, corresponding 1000s of directories and 1000s of modified copies to deal with. Just a nightmare…


#13

Thanks I will try the feedback feature…


#14

This is why I’m asking to open source apps such as NeoReader. (E.g. at Wishlist for Firmware 2.x .)
Or to maintain the system reader as a fork of existing libre software such as https://github.com/koreader/koreader or https://sourceforge.net/projects/crengine/
Right now it’s not making money for Onyx — it’s costing them money (in development and support resources), it’s costing them goodwill (witness this thread), and it’s losing the opportunity to benefit from the work of happy users.

(I know this is entirely their decision, and I know it also has downsides that need to be weighed.)


#15

I can’t agree more. I would have fixed it myself if it were open source… Since it is so important for my workflow reading papers (and the sunk cost that I brought it).