Not charging of max 2pro


#1

My Max 2 pro got hanged at 9%battrey last night and in the morning it’s showing plug in battery sign.
I’ve kept it on charging more than 5 hour it not responding a bit , not even light is blinking .
Pls help


#2

Have you tried different chargers and/or cables?

My Note Pro 10.3 does charge fine on most USB ports (chargers or computers), but it won’t charge at all on the turbo charger that came with my Pixel 2XL. I can only speculate as to why, but I believe turbo chargers use some protocol to identify the exact power needs of the connected device.

Edit: After writing the above I tried that charger again, that time with a cable that is mostly made of adapters (C-OTG->USBmini->micro->C). With that “cable” the Note charges. With the original USB-C -> C cable it does not.

Regards, Jan


#3

Hello Nitya, please kindly use the 5V 2.4A charger and original USB cable to charge the device for several hours first.


#4

just a note, charging via USB-C is significantly more complex than with earlier versions of USB, and it seems that a lot of the low-end cheap chargers do not implement all the smarts that high-end chargers have. The Raspberry Pi 4 is able to run from low-end chargers, but not high-end chargers due to a mistake in their circuit (having two pins share one resister rather than each having their own makes it identify as a non-chargable device to the charger)

I know nothing about the internals of these new devices, but I suspect that something similar is happening here.