Boox note 2 certification problem

Boox Note 2 not recognizing certification, although it was whitecleared via xda site. Two GSF ID’s were generated for the device, the second after factory reset as firmware update had not worked. Both seem to be registered correctly, but device is still not certified and can not sign in into Google play (get not certified message). Please help.

ok I found the fix myself: I had to install the latest firmware manually although it seems from Onyx that I already had the latest firmware. I was recommended by both Onyx and Amazon.com to do this to fix the problem that the device had out of the box that it was not recognizing the network/server although wi-fi worked perfectly. I did this once and a second time after doing a factory reset. Finally the network/server kicked in but then I could not get Google Play certification to work. So finally what I did is another factory reset but this time I did not install the firmware update (because Onyx had told me my build number corresponded to the latest although after having told me to do the update manually to fix the network error). So I got a third GSF ID and waited this time less than 30 minutes and I could then sign in to GooglePlay with no problem.