Max2/Neoreader corrupt PDF documents & lose highlights/scribbles since 2.2.1 firmware update

Since the last firmware update in the last days of november I have been unable to save my PDF highlights and notes.

This is how it works (doesn’t work really):

I work as usual on my document, go back to the library section of the main menu, open the document again and there they are the highlights and notes I have been done (also I can browse them in TOC option). The same thing occurs when the device enters the screensaver mode and I continue my work before the device is turned off.

It’s when the device turned itself off, or by me, hours later or the day after, and I turned it on again when EVERYTHING I’VE DONE IS LOST. I noticed this to happen since the last firmware update two weeks ago (v2.2.2). This did not happen in v2.2.1.

It seems to be another bug possibly related to this big one: when turned on again the library section on the main menu appears blank, empty, with no documents. I must have to select other section (i.e. apps, or storage) and select library again to see my documents.

I read today that Max3 and Note2 are receiving this week a firmware patch that especifically address this bug. But what about me and the thousands of Max2 users all over the world?

By the way, since this very last firmware update I am no more able to send to Onyx support any comments directly from my device, as this option, located in the config section, allow me to enter the text and my email but it cannot connect to Onyx server to complete the notification.

Have passed this bug to our relative colleagues and they will fix it as soon as possible.

Hi again.

I discover my problem on losing highlights and notes as being caused by a corrupted PDF. I am unable to open it with Adobe Reader, that show an Error 14 message. Max2 (NeoReader) opened and managed it anyway except for saving the changes.

Thank you for your attention.

1 Like

Hi once more.

I’ve just experienced this issue again in another PDF document that previously I’ve been using normally.

My conclusion is that Neoreader corrupted the PDF at certain point.

I can assure that the PDF was not corrupted when I copied it in the internal storage of my Max2.

It’s now, after approximately a week of normal use, making highlights and scribbles almost every day for many hours, that I’m not able to see none of them, despite of the day there were made.

I demand an explanation of this behaviour, as it’s not admissible that I lost my time, my effort and my money repeating everything I do every time I work with a PDF document.

This occurs since last firmware update (v2.2.1) as I noted at the top of this thread.

If you provide me an email I can send you the two PDFs, the original one and the one that have been corrupted by your hardware/software. As I noted too feedback form on the device is almost always disabled for any reason and do not allow me to upload files.

Is there any way of recovering highlights & scribbles? Are they stored in the internal database? Original PDF has a size of 1,33 MB and corrupted PDF a size of 5,50 MB so I guess the info is stored within the PDF.

I connected the Max2 to my PC and tried to open the PDF in the internal storage with Adobe Reader: it shows the error #14 (corrupted file) and It can’t be open. I copied it to my hard disk and the same error persists.

Nevertheless, I can visualize the PDF correctly, including highlights and scribbles, if I open it in Chrome as a new tab. But in this way I lose the color (black, gray are showed as yellow) and also the underline type (continued underline, discontinued underline or curvy underline are all three showed as continued) of my highlights. Scribbles are Ok. But this lose of information is not a valid option for me as I buyed the Max2 device precisely not to have to use a LCD screen.

By the way, this Chrome method allowe me to discover that there are many paragraphs I clearly have highlighted all along the text that doesn’t appear in the annotated document. It’s as if there were blanks in certain places. Related or not to the corruption problem it’s a proof of Max2/Neoreader not being reliable to save the integrity of my work.

I suggest you to send it also via the “feedback” form on the device. Onyx tend to prefer that.

1 Like

I notice the same thing on my Max 3 v2.2.2.

Update?

I did that and no replies.

It is Chines new year time now.

The original message was posted a month before Chinese New Year.

I see you are responding to messages again. Is there an update?

So I haven’t experience this issue yet but it was brought to my attention by @Xoanohn when he post something about this on my forum post. I’d like to know more about the issue because I use the Max3 for work and having corrupted files that I can’t open would be a huge problem for me in the future. It seems like from this post

that you’re able to view all your previous notes and scribbles on the Max2 is this correct? But when you say “except for saving the changes” it this natively on the Max2 or externally with some PDF viewer? Also does that mean any changes made to the document after you opened it on the Max2 aren’t saved and how does it do this? Does it actually not allow you to press the save button, does it not allow you to make scribbles or notes, or does the PDF when opened externally not show any of those changes?

So a quick google search and reading the Adobe forums I see other people are having the error #14 message and they believe that its either an Adobe issue or that “often it’s due to outdated Adobe software.” They say that “PDF documents set up with the most recent Adobe software won’t always open in earlier AR versions”. Have you tried another PDF viewer other than Adobe (i.e BlueBeam Revu, Foxit, etc.) and are you using the latest version of Adobe Reader? I’d say that because you can open it in Chrome and I believe Chrome uses Adobe Reader as it’s default PDF viewer that your issue might be the later. So I’d check to see if there an update of Adobe Reader on your PC.

The Internet’s answer about it being a version issue isn’t to far out there I mean .PDF are a file format I’d equate it to trying to open a .doc file that was generated in Word 20’ document using Word 97’ it just won’t open because it’s an incompatible file format.

I wait to hear your response because I’d like to troubleshoot this issue as much as I’m willing to improve the Onyx Boox products because compared to the other products on the market it’s ahead of anyone else for me incorporating it into my workflow. Others had some major productivity flaws that ruled them out as viable replacement to me using paper and pen.