Interface now in Chinese only after update. Help!

Since Onyx—after many requests—still has not provided a link to a website providing firmware download links for the Boox Note Lite, I followed the procedure that Claire advised me by email a while back to update to the most recent firmware.

I was told that OTA updates wouldn’t work when the interface is set to English, so I should change it to Chinese, figure out the correct update buttons, run the OTA update, and after rebooting change the language back to English again.

The update part has worked, it now indicates I am on 2.2.2
But, the option to change the language to anything else than Chinese is gone.
So I am now stuck with Chinese.

How can I get the interface back in English?

Last icon in the left sidebar for settings > globe icon > first entry is the language selection > select English.

The only language choice there now is Chinese, nothing else.

Then you can try this app from the Play Store:

When you install this app, you can access the Android settings. In the Android settings try this:
Last icon for system > second icon for languages & input > first icon for system language.

English should be available there.

1 Like

Thanks for your replies and that suggestion @hazington.

But before I get myself even deeper in this rabbit hole I think it is better to await a reponse from Onyx on this first.

Onyx’s response time is unacceptable. My first bug was reported here on the 28th of December and I am still waiting for any response. I wrote Onyx an email on the 20th of October and they just referred me to this forum. Sometimes Claire answers here, but Onyx support ist quite poor, to be honest. Maybe they will respond, if you send them a message via Facebook.

They can only suggest you a full reset that will cause data loss. That’s it. Nothing else can be done here. Trying to set the language via Android settings usually won’t harm your system. It’s worth a try. But anyways, first backup anything relevant. Did you restart your Onyx? Maybe the other languages are then available. If not, try the Android settings.

I will write a post within the next days that includes all known bugs in Version 2.2.2. Unfortunately I have already written four DIN A5 pages full of bugs.

Well, since it is new years time I will be a bit patient.
And maybe there are some festivities going on ‘over there’.

Thankfully my books are not changed to Chinese :wink:

I see that the Chinese new year’s festivities start on Januari 25th.
So it would be nice if there could be an answer/solution for my problem before that…


After the update to 2.2.2 my Onyx Note is still unusable due to it’s now non-English, Chinese-only interface.


I already tried to help you. There are still two options. Try the recommended app and use the Android settings or do a factory reset. I explained the factory reset here:

1 Like

thanks again @hazington!

I did do a factory reset.
(Obviously losing all my loaded books and preferences :frowning:

But the user interface language option is still Chinese, Chinese, or Chinese.

No hurries though. I am confident that Onyx/ @Claire will provide the solution shortly after this weekend.

(I am sure that they are also very uncomfortable and dissatisfied that they took my money for a product that is now useless to me)

Dear @Claire,

Could you please be so kind to forward this problem to a relative colleague of yours who does care about one of your customers having spend serious money on an Onyx Boox Note ereader less than a year ago, that is currently completely unusable and collecting dust?

Thank you, much appreciated.

Hello, sorry for the late reply here. Our relevant colleague will contact you via email later.

Just in case anybody reading this is interested, I was never contacted.
No support.